macOS Big Sur 11.1 Ryzen Build! : hackintosh
Driver on

macOS Big Sur 11.1 Ryzen Build! : hackintosh

System Specs:

CPU: Ryzen 5 3600
GPU: MSI RX 5500 XT 8GB Mech over DisplayPort
RAM: 16GB Patriot Viper (3866MHz XMP)
Storage: Sabrent 1TB Rocket NVMe SSD (Home windows Boot Drive), Essential M4 128GB SSD (MacOS Boot Drive)
Motherboard: Gigabyte B550I AORUS PRO AX
Audio Codec: ALC1220
Ethernet Card: Realtek 2.5GbE LAN 
Wifi/BT Card: AX200
BIOS revision: F11p
Opencore Model: 0.6.4
Information: https://dortania.github.io/OpenCore-Set up-Information/
SMBIOS: MacPro7,1
BootArgs: keepsyms=1 agdpmod=pikera npci=0x3000 alcid=21
Kexts: AirportItlwm, AppleALC, AppleMCEReporterDisabler, IntelBluetoothFirmware, IntelBluetoothInjector, Lilu, NullCPUPowerManagement, VirtualSMC, WhateverGreen.

After numerous hours of modifying random recordsdata and tweaking BIOS settings I’ve lastly managed to get my Twin-Booted Home windows/macOS system to work (largely) flawlessly! Just a few issues price mentioning:

Issues primarily arose from having the M.2 Drive plugged into the motherboard – for some cause this messes fully with PCIe-lane task so my graphics card was not working correctly on macOS and on Home windows. In macOS it could simply lag and stutter continuously and in Home windows AMD drivers wouldn’t set up and would lead to black screens/driver crashes. This was resolved by transferring the NVMe SSD from the entrance M.2 Connector to the again of the motherboard connector and altering the PCIe lanes to 2×8 mode from Auto. This additionally solved the dearth of Bluetooth engaged on each Home windows and macOS.

Attempting to make use of AMDRyzenCPUPowerManagement Kexts did not work out for me and resulted in unstable efficiency with mouse stuttering and normal software program lag. This resulted in me downloading an outdated model of NullCPUPowerManagement Kexts which ended up working.

Within the information it tells you to allow Above4GDecoding within the BIOS, however for me with this on, my system did not work. Turning it off allowed me to get into the macOS installer. So if issues aren’t understanding, strive turning it off it would can help you boot.

When putting in Home windows onto the second drive, it is necessary to unplug the macOS drive (for twin drive programs) as in any other case your macOS EFI shall be overwritten by Home windows (I discovered the laborious manner).

What’s working:

  • Bluetooth/Wifi (though speeds are considerably decreased) – by the usage of AirportItwlm and IntelBluetoothFirmware.

  • iServices – all messages sync over iCloud and I’m able to use Siri and FaceTime in addition to continuity options and so forth.

  • All USB ports – I have not actually needed to tweak something for this or reassign lanes.

  • Correct sleeping/wake options.

  • Audio – utilizing Apple ALC kexts, though the standard is considerably decreased . Attempting all of the potential layouts although I deduced that, for my {hardware} format 21 sounded and labored the most effective.

What’s not working:

  • Airdrop and Sidecar – however I believe that is to be anticipated for a Hackintosh.

  • Disney+ Streaming on Safari, though different DRM content material works on different providers comparable to Netflix and Amazon Prime Video.

  • Microphone Ports – which is extra of an Ryzen compatibility factor, nonetheless USB mics and AirPods microphone over bluetooth works advantageous.

  • M.2 Drive reveals as an exterior drive and I can not format it in macOS.

r/hackintosh - macOS Big Sur 11.1 Ryzen Build!

Leave a Reply

Your email address will not be published. Required fields are marked *