How do I install the Nvidia drivers?
Driver on

networking – How to install (or troubleshoot) a USB 3.0 AX88179 Gigabit Ethernet adapter?

I’ve a USB 3.Zero AX88179 primarily based Gigabit Ethernet adapter and after looking out on-line, I discovered many individuals reporting success with this machine underneath Linux. The motive force entered the mainline kernel on model 3.9, however even earlier than that, downloading the drivers from the the ASIX web sites, compiling and loading the driving force manually ought to work wonderful.

Sadly this isn’t the case for me on Ubuntu 12.10 and 13.04 on a Dell XPS 13 Developer Version. I compile the driving force (v1.4.0) with none issues (make, make set up), I load it utilizing modprobe and I see it as eth2. I may even see some RX/TX visitors nevertheless it can not purchase an IP handle so it’s unusable.

dmesg output:

[ 1338.583575] ASIX USB Ethernet Adapter:v1.4.0 10:01:27 Jun 26 2013
[ 1338.583575]          http://www.asix.com.tw
[ 1338.583599] ax88179_178a 4-2:1.0 (unregistered net_device): mtu 1500
[ 1338.584080] ax88179_178a 4-2:1.Zero eth0: register 'ax88179_178a' at usb-0000:00:14.0-2, ASIX AX88179 USB 3.Zero Gigibit Ethernet, 00:24:9b:06:6a:85
[ 1338.585110] usbcore: registered new interface driver ax88179_178a
[ 1338.932157] IPv6: ADDRCONF(NETDEV_UP): eth2: hyperlink will not be prepared
[ 1338.933382] IPv6: ADDRCONF(NETDEV_UP): eth2: hyperlink will not be prepared
[ 1341.887977] ax88179_178a 4-2:1.Zero eth2: ax88179_178a - Hyperlink standing is: 1
[ 1341.889595] ax88179_178a 4-2:1.Zero eth2: Write medium kind: 0x013f
[ 1341.890699] IPv6: ADDRCONF(NETDEV_CHANGE): eth2: hyperlink turns into prepared
[ 1341.891748] ax88179_178a 4-2:1.Zero eth2: hyperlink up, 1000Mbps, full-duplex, lpa 0xC1E1

ifconfig output:

eth2      Hyperlink encap:Ethernet  HWaddr 00:24:9b:06:6a:85  
          inet6 addr: fe80::224:9bff:fe06:6a85/64 Scope:Hyperlink
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:76623 errors:1 dropped:22802 overruns:Zero body:1
          TX packets:302 errors:Zero dropped:Zero overruns:Zero provider:0
          collisions:Zero txqueuelen:1000 
          RX bytes:2601276 (2.6 MB)  TX bytes:109741 (109.7 KB)

A distinct USB 2.Zero Gigabit ethernet adapter and the WiFi are each working wonderful, so networking should not be an issue on my laptop computer. Is there one thing I miss for this particular chipset?

FOLLOW UP

With the newest Kubuntu (and I assume Ubuntu as nicely) is working! So the issue is fastened. I assume it was a driver/kernel/{hardware} difficulty which isn’t current anymore with the newest kernel. I can not inform the precise kernel model which made it to work, however for Trusty 14.04 every thing appears to be like wonderful!

Leave a Reply

Your email address will not be published. Required fields are marked *